Announcement

Collapse
No announcement yet.

Trane ComfortLink II XL1050 Flashing “–” in Humidity Display

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trane ComfortLink II XL1050 Flashing “–” in Humidity Display

    I have a Trane ComfortLink II XL1050 Wi-Fi Thermostat (https://shop.rfwel.com/trane-tzon105...fi-thermostat/). I started seeing “–” flashes in humidity display with no readings. What do I need to do to resolve this issue?
    Last edited by Lameck; 07-21-2021, 02:03 PM.

  • #2
    “–” flashes in humidity display of your Trane ComfortLink II XL1050 Wi-Fi Thermostat can be an indication that the humidity reading is outside of measurable range. This can also be as a result of fault with your humidity sensor.

    Try to power cycle the internal humidity sensor. To do this, first, locate the HVAC system power circuit. Since it is already in the ON position, flip it to the OFF position and then back to the ON position.

    Turn the thermostat OFF and then ON again.

    If the problem persists, please check out your external humidity sensor. Confirm that Hs and Hp terminals are well functional. If the terminals are intact you should try removing and adding the sensor afresh. In case this fails to work your sensor may be damaged/malfunctioned and you should consider replacing it.

    Trane ZSENS930AW00MA and TH100NX are Humidity sensors that you can consider.

    For other custom HVAC control solutions, feel free to contact our HVAC experts for assistance.

    Comment

    Working...
    X